{title}

Hallo zusammen, wie würde ich vorgehen, um eine Batch-Datei zu erstellen, die eine Textdatei liest, und wenn die Textdatei ein bestimmtes Wort enthält, führen Sie eine bestimmte Aktion aus? Ich möchte, dass meine Batch-Datei prüft, ob die Textdatei EXAMPLE.txt EXAMPLEWORD enthält, und ob die Batch-Datei mit dem Code fortfahren soll, oder ob nichts unternommen wird, wenn EXAMPLEWORD nicht gefunden wird. Vielen Dank im Voraus, Kamak

Code: für / f "tokens = delims =" %% v in ('type example.txt ^ | find "EXAMPLEWORD"') do echo %% vDieses Beispiel führt die echo-Anweisung aus, wenn das Argument gefunden wird. Sie können dies in eine beliebige Anweisung ändern, die Sie ausführen möchten. Bei der Suche nach EXAMPLEWORD wird zwischen Groß- und Kleinschreibung unterschieden. Fügen Sie den Schalter / i zum Befehl find hinzu, um die Groß- und Kleinschreibung zu vermeiden.

Ich bin sicher, dass findstr eine Datei als inputCode aufnimmt: findstr / I / G: Datei "STRING to SEARCH" && execute_command

Findstr nimmt eine Datei oder empfängt eine Eingabe über eine Pipe, wie das Beispiel von Sidewinder zeigt.

yup, es wäre also unnötig, type zu verwenden, nicht dass es sowieso eine große Sache wäre

findstr / I "Zu durchsuchender String" filename.txt> nul && execute_command

Vielen Dank, Sie waren wirklich hilfreich

JxIi1Vho0kA

Funktionen und Features in 3D-Funktionen

Hallo, ich habe ein Problem, das hier scheinbar noch niemand gesehen hat, ich habe alles ausprobiert, Foren, Helpdesks, Expertenaustausch, ATI-Support, ASUS-Support und niemand kann mir helfen:
Ich habe eine brandneue RADEON 9800 PRO R350 gekauft und sehe Flackern in 3D-Anwendungen und Linien aus der Mitte des Bildschirms. Es passiert in allen 3D-Anwendungen, Bildschirmschonern, Spielen. Sehen Sie sich ein Beispiel in einem 10-Sekunden-Video an:
//etudiant.tim.cstj.net/2001/9956138/flickers.mov
Folgendes habe ich versucht:
- Alte ATI 9000-Treiber mit Driver Cleaner reinigen
-Installation der neuesten UND alten Treiber vom ATI 9800
-Installiertes Original-BIOS und aktualisiertes BIOS
- Löschen des CMOS mit dem Jumper auf der Hauptplatine, um die werkseitigen Standardeinstellungen wiederherzustellen
- Ziehen Sie die Diskette, beide CD-ROMs, eine Festplatte, alle USB-Geräte, den Drucker und jedes PCI-Gerät heraus, um Energie für den VGA-Adapter zu sparen
- Versucht einen Stromversorgungsrechner:www.jscustompcs.com/power_supply/ um zu sehen, ob mein Netzteil in Ordnung war: Ich benötige 315 Watt und mein Netzteil ist 350 Watt.
-Formatierung und Neuinstallation von Windows
- Bringen Sie den Grafikadapter wieder in den Laden, um einen neuen zu erhalten
-Nehmen Sie alle möglichen Kombinationen von Spannungen und Einstellungen für den AGP-Steckplatz im BIOS vor
-Entfernen Sie jedes einzelne Staubpartikel im AGP-Schlitz mit einem Staubsauger
DAS EINZIGE, WAS FUNKTIONIERT:
Wenn ich meinen Computer auf eine unmögliche Kombination im BIOS übertakte, startet der Computer und sagt:
Übertakten fehlgeschlagen
F1 - Setup ausführen
F2 - Standardeinstellungen
Wenn ich F2 drücke, funktioniert alles! aber meine CPU Geschwindigkeit ist 1300 MHz statt 2600 und sobald ich
starte meinen computer neu, das flackern fängt wieder an, auch wenn ich es nicht tue! Führen Sie Setup während des Bootvorgangs aus
Einen vollständigen Lebenslauf meines Computers finden Sie unter folgender Adresse:
//etudiant.tim.cstj.net/2001/9956138/report.htm
In diesem kleinen Abschnitt des Berichts:
//etudiant.tim.cstj.net/2001/9956138/agp.htm
Sie können sehen, dass der AGP-Steckplatz leer ist
Es scheint also, dass das Problem vom Motherboard herrührt
Ich habe einen Monat lang sowohl an ATI als auch an ASUS geschrieben, aber es scheint ihnen egal zu sein, da sie nicht wissen, wie sie das Problem lösen sollen, und sie antworten immer mit dummen Antworten und Dingen, die ich ihnen bereits gesagt habe, oder sie sagen mir, ich solle den neuesten Treiber installieren !! Als hätte ich alles getan, hätte aber nie daran gedacht, den neuesten Treiber zu installieren! Dann geben sie das Problem an eine andere Person weiter, und diese Person fordert mich auf, den neuesten Treiber zu installieren, damit es nirgendwo hinkommt.
Das erste Mal, dass ich das Licht am Ende des Tunnels nicht sehe, habe ich normalerweise immer einen Plan B, aber jetzt, wenn ihr mir nicht helfen könnt, habe ich absolut keine Ahnung, was ich tun soll, es ist Für eine Rücksendung der RADEON 9800 ist es jetzt zu spät. ATI und ASUS waren zu langsam. Seit dem Kaufdatum ist bereits ein Monat vergangen.
Hier ist ein kurzer Bericht über meinen Computer, nach dem mich ASUS gefragt hat
Produkttyp: Hauptplatine
Produktmodell: P4C800 Deluxe
Motherboard-Revision: 1.03
BIOS-Revision der Hauptplatine: 1011
< br>
VGA-Kartenanbieter: ATI
VGA-Kartenmodell: Radeon 9800 pro R350 128 MB
VGA-Karten-Chipsatz: ATI
VGA-Kartentreiber: vga.sys 5.1.2600.1106
CPU-Hersteller: Intel
CPU-Typ: Sockel 478
CPU-Geschwindigkeit: 2600 MHz
Speicheranbieter: Unbekannt
Speichermodell: DDR SDRAM
Speicherkapazität: 1024 MB
HDD-Anbieter: Seagate
HDD-Modell: 3JT0GNZL & 3JT0GNV! G
Festplattenkapazität: 2 x 120 GB
Betriebssystem: Windows XP PRO
Wenn mir niemand helfen kann, haben Sie wenigstens eine Idee, was zu tun ist, wie mir die Adresse von jemandem zu geben, den Sie kennen und der VIEL über Computer Bescheid weiß, weil ich wirklich einen vollständigen Experten brauche.
Danke, dass du das hier gelesen hast, hehe

Diagnose ausführen >>www.active-hardware.com/english/misc/sandra.html
Überhitzung / Übertaktung / schlechter Chip usw. Kann die Ursache sein? Versuchen Sie es mit 8.10. Möglicherweise ist der p4 zu schnell für das verwendete Programm. Schauen Sie sich einen CPU-Killer an.

Ich habe die Software heruntergeladen, aber ich habe keine Ahnung, was ich damit anfangen soll. Sie ähnelt Everest, der Software, mit der ich den vollständigen Bericht erstellt habe.
Und meine CPU ist in Ordnung, alle 3D-Anwendungen liefen perfekt mit meiner alten RADEON 9000, die Probleme begannen, als ich die RADEON 9800 installierte und ich die neueste 9.0c-Version von DirectX habe

oder hast du damit gemeint, directx 8.1 zu installieren?
Wenn ja, ist dies etwas seltsam, da viele 3D-Anwendungen mindestens DirectX 9.0 benötigen. Wenn dies funktioniert, kann ich nicht alle Anwendungen verwenden


1. Das Netzteil scheint an den Rand geschoben zu sein. 350 Watt lassen nicht viel Spielraum.
2. Ich verstehe nicht ganz, was das bedeutet. Standardeinstellungen funktionieren, außer CPU-Geschwindigkeit ist die Hälfte?

1.Kann nicht das Netzteil sein, ich habe fast alles ausgesteckt:
Es gab nur eine Festplatte, den Prozessor, 2 Speicherchips, die Maus, die Tastatur und den Grafikadapter. Ist es wirklich möglich, dass die Stromversorgung so schlecht ist?
2.Sie haben verstanden, dass, wenn ich mein CMOS mit dem Jumper auf dem Motherboard zurücksetze, alle Spezifikationen auf den Standardwert gesetzt werden, aber wenn ich mir die Systemeigenschaften ansehe, ist die CPU-Geschwindigkeit halb so hoch. Und sobald ich neu starte, ist alles wieder normal: CPU normale Geschwindigkeit, Grafikadapter alle? # $? Nach oben


1. Ich stimme zu, nicht die Stromversorgung.
2. Nach dem Zurücksetzen des CMOS müssen Sie möglicherweise einmal CMOS eingeben und die Einstellungen speichern. Danach sind die Einstellungen wahrscheinlich korrekt. Überprüfen Sie dies, indem Sie nicht unter Windows booten. Geben Sie das zweite Mal CMOS ein, um zu überprüfen, ob die CPU korrekt gemeldet wird.
Diese Hochleistungs-CPUs (und Grafik-CPUs) sind hinsichtlich der Spannung sehr wählerisch. Wenn Mobo ein bisschen daneben ist, wird es nicht glücklich sein. Sie können versuchen, die Spannungen im BIOS anzupassen.

Ja, das habe ich schon versucht, ich habe das BIOS nach dem Zurücksetzen eingegeben und gespeichert und neu gestartet, ohne etwas zu ändern, aber trotzdem war die CPU-Geschwindigkeit in Ordnung und der Grafikadapter wurde wieder verrückt.
Es sieht so aus, als gäbe es immer zwei Möglichkeiten:
1-Die CPU ist normal, die RADEON jedoch nicht
2-Die CPU ist nicht normal, aber die RADEON ist
Ich habe auch versucht, die Spannung der RADEON, die standardmäßig auf 1,50 V eingestellt war, auf 1,60, 1,60 und 1,80 (Maximalwert) zu erhöhen, aber das hat nichts geändert.
Und ich weiß nicht viel über die CPU-Spannung, sollte:
-Höhere CPU-Spannung und höhere RADEON-Spannung?
-Höhere CPU-Spannung und niedrigere RADEON-Spannung?
Blöde ASUS-Unterstützung, ich gab ihnen mein Motherboard-, CPU- und Grafikadapter-Modell, sie wären in der Lage, dieses Problem schnell zu lösen, wenn sie sich nur darum kümmern würden.
Und was halten Sie davon, dass der AGP-Slot in diesem Bericht leer ist:
//etudiant.tim.cstj.net/2001/9956138/agp.htm
Könnte es ein Spannungsproblem sein?
Übrigens, vielen Dank, dass Sie mir die Zeit gegeben haben, für die Sie nicht bezahlt haben, während ASUS mir nicht die Zeit gibt, für die Sie bezahlt haben.
Marco


Das brachte mich zum Nachdenken. Die AGP-Geschwindigkeit ist ein Multiplikator der FSB-Geschwindigkeit. Ich denke, der Täter ist die Grafikkarte oder eine AGP-Einstellung im BIOS. Aus diesem Grund lautet der Bericht "AGP = leer".
Versuchen Sie dieses Dienstprogramm:
Geben Sie bei Start-Ausführen Folgendes eindxdiag. Was steht auf der Registerkarte Anzeige?

Hallo, vielleicht hast du das Problem gefunden?
Auf der Verkaufsbox meiner CPU steht: 800 MHz Systembus
im BIOS kann ich dort den FSB einstellen, da dies heißen soll: Front Side Bus, ist das das selbe? weil ich es im BIOS nur von 100 auf 400 einstellen kann.
Und im everest-Bericht heißt es, der ursprüngliche FSB sei 200 MHz. Was ist was?
Hier sind die Anzeigeeigenschaften von dxdiag: Ich habe die Direct3D-Tests nur auf dem ersten Monitor ausprobiert:
Kartenname: RADEON 9800 PRO
Hersteller: ATI Technologies Inc.
Chiptyp: Radeon 9800 AGP (0x4E48)
DAC-Typ: Interner DAC (400 MHz)
Geräteschlüssel: Enum PCI VEN_1002 & DEV_4E48 & SUBSYS_00021002 & REV_00
Anzeigespeicher: 128,0 MB
Aktueller Modus: 1600 x 1200 (32 Bit) (75 Hz)
Monitor: Plug-and-Play-fähig
Monitor Max Res: 1600,1200
Treibername: ati2dvag.dll
Treiberversion: 6.14.0010.6343 (Englisch)
DDI-Version: 9 (oder höher)
Fahrerattribute: Final Retail
Treiber Datum / Größe: 28.04.2003 21:39:48, 291584 Bytes
WHQL Logo'd: n / a
WHQL-Datumsstempel: n / a
VDD: n / a
Mini VDD: ati2mtag.sys
Mini VDD Datum: 28.04.2003 21:39:24, 625920 Bytes
Gerätekennung: {D7B71EE2-0D08-11CF-756B-0820A1C2CB35}
Hersteller-ID: 0x1002
Geräte-ID: 0x4E48
SubSys ID: 0x00021002
Revisions-ID: 0x0000
Revisions-ID: 0x0000
Videobeschleunigung:
Deinterlace Caps: n / a
Registrierung: OK
DDraw-Status: Aktiviert
D3D-Status: Aktiviert
AGP-Status: Nicht verfügbar
DDraw-Testergebnis: Alle Tests waren erfolgreich.
D3D7 Testergebnis: Alle Tests waren erfolgreich.
D3D8 Testergebnis: Alle Tests waren erfolgreich.
D3D9 Testergebnis: Alle Tests waren erfolgreich.
Kartenname: RADEON 9800 PRO - Sekundär
Hersteller: ATI Technologies Inc.
Chiptyp: Radeon 9800 AGP (0x4E48)
DAC-Typ: Interner DAC (400 MHz)
Geräteschlüssel: Enum PCI VEN_1002 & DEV_4E68 & SUBSYS_00031002 & REV_00
Anzeigespeicher: 128,0 MB
Aktueller Modus: 1600 x 1200 (32 Bit) (75 Hz)
Monitor: Dell D1626HT
Monitor Max Res: 1600,1200
Treibername: ati2dvag.dll
Treiberversion: 6.14.0010.6343 (Englisch)
DDI-Version: 9 (oder höher)
Fahrerattribute: Final Retail
Treiber Datum / Größe: 28.04.2003 21:39:48, 291584 Bytes
WHQL Logo'd: n / a
WHQL-Datumsstempel: n / a
VDD: n / a
Mini VDD: ati2mtag.sys
Mini VDD Datum: 28.04.2003 21:39:24, 625920 Bytes
Gerätekennung: {D7B71EE2-0D28-11CF-756B-0920A1C2CB35}
Hersteller-ID: 0x1002
Geräte-ID: 0x4E68
SubSys ID: 0x00031002
Revisions-ID: 0x0000
Revisions-ID: 0x0000
Videobeschleunigung:
Deinterlace Caps: n / a
Registrierung: OK
DDraw-Status: Aktiviert
D3D-Status: Aktiviert
AGP-Status: Nicht verfügbar
DDraw-Testergebnis: Nicht ausgeführt
D3D7 Testergebnis: Nicht ausgeführt
D3D8 Testergebnis: Nicht ausgeführt
D3D9 Testergebnis: Nicht ausgeführt

Busgeschwindigkeit ist 800 (200 FSB 4)
CPU-Geschwindigkeit 200 13 = 2600 (13 wird von der CPU gesperrt)
AGP-Geschwindigkeit 200 4 2/3 = 533
Hat das Motherboard eine Einstellung für den AGP-Multiplikator? Wenn ja, auf 2/3 setzen.
Aus Ihrem Bericht:
AGP-Eigenschaften:
AGP Version 3.00
AGP-StatusDeaktiviert
AGP Aperture Size 128 MB
Unterstützte AGP-Geschwindigkeiten 1x, 2x, 4x, 8x
Fast-Write unterstützt, deaktiviert
Seitenbandadressierung unterstützt, aktiviert
Probleme & Vorschläge:
ProblemAGP ist deaktiviert. Dies kann zu Leistungseinbußen führen.

Woohooo! Also, das ist das Problem. Hast du eine Idee, wie man das korrigiert?
Ist es immer so? Ich meine, CPU Speed13 und FSB4?

Oh, und ich weiß auch nicht, wie ich den Multiplikator einstellen soll, liegt das im BIOS? Wenn ja, wie lautet der "BIOS" -Begriff für diesen Multiplikator?

@# # $? Ich habe in Everest nachgesehen, um mir das Problem genauer anzusehen, und jetzt heißt es:
AGP-Controller:
AGP Version 3.00
AGP-Status aktiviert
AGP-Gerät ATI Radeon 9800 Pro
AGP Aperture Size 128 MB
Unterstützte AGP-Geschwindigkeiten 1x, 2x, 4x, 8x
Aktuelle AGP-Geschwindigkeit 8x
Fast-Write unterstützt, deaktiviert
Seitenbandadressierung unterstützt, aktiviert
Vielleicht habe ich etwas deaktiviert, als ich den Bericht erstellt habe, aber jetzt wacht er immer noch nicht auf, selbst wenn er aktiviert ist.
Aber was ist mit dem, was Sie über dxdiag gesagt haben, als Sie sagten:
Das brachte mich zum Nachdenken. Die AGP-Geschwindigkeit ist ein Multiplikator der FSB-Geschwindigkeit. Ich denke, der Täter ist die Grafikkarte oder eine AGP-Einstellung im BIOS. Aus diesem Grund lautet der Bericht "AGP = leer".
Versuchen Sie dieses Dienstprogramm:
Geben Sie bei Start-Ausführen dxdiag ein. Was steht auf der Registerkarte Anzeige?

Übrigens habe ich den Bericht im Web aktualisiert

Mir gehen die Ideen aus. Versuchen Sie, Fast-Write zu aktivieren. Ich denke, das ist im BIOS "Performance Mode". Wechseln Sie von Auto zu Turbo.
ATI sagt: "Mit Fast Write kann die CPU Daten direkt an den Grafikbeschleuniger übertragen." Bericht sagt, dass es unterstützt, aber deaktiviert ist.
AGP-Eigenschaften:
AGP Version 3.00
AGP-Status aktiviert
Unterstützte AGP-Geschwindigkeiten 1x, 2x, 8x
Aktuelle AGP-Geschwindigkeit 8x
Fast-Write unterstützt, deaktiviert
Seitenbandadressierung unterstützt, aktiviert

Ich hatte ein ähnliches Problem. Es scheint ein Inkompatibilitätsproblem mit Ihrer Grafikkarte und der Hauptplatine zu geben, das zu Flimmern, Artefakten und sogar zu einem Neustart führen kann.
versuchen Sie es mit einer anderen Grafikkarte (offensichtlich keine andere Radeon 9800-Serie)! Hoffe das hilft
Asche

Hehe, sagte euch allen die Ideen ausgehen
Ich schätze, ich werde es versuchen, und wenn es nicht funktioniert, werde ich versuchen, meinen Computer zu einem Servicegeschäft zu bringen (autsch $$$), und wenn das immer noch nicht funktioniert, gehe ich mit Ashley Lutchmunsing Lösung und vielleicht ein neues Motherboard kaufen

Vze -_- FDGw4

Beliebte Beiträge